README.md: bump GCC requirement to version 6 or later

GCC 5 supports C++14, but it is still not enough because it does not implement
N4387 that was retroactively applied to the standard in 2015 (see the "Notes"
and "Defect reports" sections of
https://en.cppreference.com/w/cpp/utility/tuple/tuple).
parent 1238fb20
Pipeline #707 failed with stages
in 68 minutes and 54 seconds