Commit a71e0ebe authored by Sébastien Villemot's avatar Sébastien Villemot

Add a compile-time check for MATLAB version, as we already do for Octave

parent 88e89dfb
......@@ -87,7 +87,7 @@ if isoctave
skipline()
end
else
if matlab_ver_less_than('7.5')
if matlab_ver_less_than('7.5') % Should match the test in mex/build/matlab/configure.ac
skipline()
warning('This version of Dynare has only been tested on MATLAB 7.5 (R2007b) and above. Since your MATLAB version is older than that, Dynare may fail to run, or give unexpected results. Consider upgrading your MATLAB installation, or switch to Octave.');
skipline()
......
......@@ -34,6 +34,7 @@ if test "x$ax_enable_matlab" = "xyes"; then
if test "x$ax_matlab_version_ok" = "xyes"; then
AX_MEXOPTS
AX_COMPARE_VERSION([$MATLAB_VERSION], [lt], [7.5], [AC_MSG_ERROR([Your MATLAB is too old, please upgrade to version 7.5 (R2007b) at least.])])
fi
CFLAGS="$MATLAB_CFLAGS"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment