Unverified Commit ab656f2d authored by Sébastien Villemot's avatar Sébastien Villemot
Browse files

macOS/use_dll: upgrade to gcc-10 compiler

parent a0d12310
......@@ -2036,16 +2036,16 @@ ModelTree::compileMEX(const string &basename, const string &funcname, const stri
if (_NSGetExecutablePath(dynare_m_path, &size) == 0)
{
string str = dynare_m_path;
gcc_relative_path = str.substr(0, str.find_last_of("/")) + "/../../.brew/bin/gcc-9";
gcc_relative_path = str.substr(0, str.find_last_of("/")) + "/../../.brew/bin/gcc-10";
}
if (filesystem::exists(gcc_relative_path))
compiler = gcc_relative_path;
else if (filesystem::exists("/usr/local/bin/gcc-9"))
compiler = "/usr/local/bin/gcc-9";
else if (filesystem::exists("/usr/local/bin/gcc-10"))
compiler = "/usr/local/bin/gcc-10";
else
{
cerr << "ERROR: You must install gcc-9 on your system before using the `use_dll` option of Dynare. "
cerr << "ERROR: You must install gcc-10 on your system before using the `use_dll` option of Dynare. "
<< "You can do this via the Dynare installation package." << endl;
exit(EXIT_FAILURE);
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment